Du bist nicht angemeldet.

WoW-Castle auf Facebook WoW-Castle auf YouTube WoW-Castle auf Twitter WoW-Castle als RSS-Feed

DorianGrey

Fortgeschrittener

  • »DorianGrey« ist der Autor dieses Themas

Beiträge: 270

Danksagungen: 273

  • Private Nachricht senden

1

16.02.2011, 17:47

Alternativer WoW-Starter

Mal kurz und bündig - der Starter im Zip-File im Anhang automatisiert ein paar Vorgänge beim bzw. vor dem Starten von WoW.
  • Löschen des Caches
  • Umsetzen der Realmlist
  • Starten von WoW
Einige haben das wahrscheinlich schon selbst per Batch oder eigenem Code umgesetzt, der Rest kann gerne diesen Starter verwenden.
Wer's nicht brauchen kann, halt nicht ;)

Enthalten sind eine 64- und eine 32-Bit-Version, je nachdem, was ihr braucht. Kopiert einfach die entsprechende .exe ins WoW-Verzeichnis (da, wo die Wow.exe auch ist) und startet ihn. Außer dem oben genannten tut er nichts, also kein Panik.
An Interessierte kann ich auch den Quellcode rausgeben, dieser ist weder lang noch kompliziert.

~ Gruß, DorianGrey.

--------------------------------------------------------------------------------------------------------------------------------------------------------------

Evtl. auftretende Probleme:
- Meldung über fehlende DLL: msvcp100.dll, msvcr100.dll, msvcr100d.dll
- Lösung: C++ Redistributable Package nachinstallieren. Wird auch von vielen aktuelleren Spielen verwendet, daher alles andere als sinnlos.
32-Bit-Version
64-Bit-Version
»DorianGrey« hat folgende Datei angehängt:
  • WoWLauncher.zip (45,73 kB - 43 mal heruntergeladen - zuletzt: 25.04.2015, 00:53)
"Those who would give up essential Liberty to purchase a little temporary Safety, deserve neither Liberty nor Safety." - Benjamin Franklin



Laa shay'a waqu'in moutlaq bale kouloun moumkine. - Nothing is true, everything is permitted.

Es haben sich bereits 6 registrierte Benutzer bedankt.

Benutzer die sich bedankten:

Viran, Nihalejh, Absalom, Darkmann, Tarkan, nightwalker559

brighid

AdministratorIN

Beiträge: 846

Danksagungen: 37

  • Private Nachricht senden

2

16.02.2011, 20:42

habs mal oben angeheftet das es sich nicht im forum verliert
Nicht weil es unerreichbar ist, wagen wir es nicht, sondern weil wir es nicht wagen, ist es unerreichbar.

Hüte Dich vor Menschen die schon verletzt wurden.
Sie haben gelernt zu überleben.


bayo73

Anfänger

Beiträge: 3

  • Private Nachricht senden

3

17.02.2011, 06:22

wow

ich finde es eine tolle sache mit denn luncher prima weiter so mit denn tollen ideen :)

Jeff

Administrator

Beiträge: 666

Danksagungen: 38

  • Private Nachricht senden

4

17.02.2011, 09:32

Prima, hab den Beitrag von dir Dori gleich mal auch in den Hilfebereich kopiert:
http://www.wow-castle.de/bboard/wow-anle…-und-infos.html

Absalom

Schüler

Beiträge: 94

  • Private Nachricht senden

5

17.02.2011, 11:00

Hallo

Bei Win7 Ultimate 64 Bit gibt es, zumindest bei mir, Probleme, die ich mit meinen als bescheiden zu benennenden Kenntnissen nicht in den Griff bekomme.


Als ich den „WoWLauncher_x86-32“ in den Ordner kopierte und starten wollte, wurde ich Reihnach auf fehlende dll Dateien aufmerksam gemacht: „msvcp100.dll, msvcr100.dll und msvcr100d.dll“.
Nachdem ich die Dateien in den Systemordner: System32 und in das WoW Installationsverzeichnis kopierte, ("Sicher ist Sicher", dachte sich der Laie :gruebel: ), erhalte ich nun folgende Meldung: Der Prozedureinsprungspunkt „_invalid_parameter_noinfo_noreturn“ wurde im DLL „MSVCR100.dll" nicht gefunden.

Beim „WoWLauncher_x86-64“ erhalte ich hingegen folgende Meldung: "Die Anwendung konnte nicht korrekt gestartet werden (0x000007b) Klicken Sie auf OK … bla,bla,bla."



Über abhelfende Ratschläge würde ich mich trotz eines abklingenden grippalen Infektes freuen. ::kaffee::

Mfg

Nihalejh

Schüler

Beiträge: 91

Danksagungen: 21

  • Private Nachricht senden

6

17.02.2011, 12:47

Ich hab leider das selbe Problem.. Systemfehler beim starten bei win7 64 bit -.-

lg

Ich diskutiere nicht mit Idioten, die ziehen mich sonst auf Ihr Niveau hinunter und schlagen mich dort dann mit Erfahrung.

DorianGrey

Fortgeschrittener

  • »DorianGrey« ist der Autor dieses Themas

Beiträge: 270

Danksagungen: 273

  • Private Nachricht senden

7

17.02.2011, 14:11

Hm, merkwürdig. Die beiden hab ich ja selbst unter WIn7 64 Bit kompiliert, und funktioniert hier auch einwandfrei. Kann aber sein, dass er sich automatisch an den Bibliotheken des Visual-Studio-Compilers bedient ?( Aus denen wird eigentlich nichts weiter relevantes verwendet.

Versuchts mal mit der Installation vom C++ Redistributable Package.
32-Bit-Version
64-Bit-Version

Sollten die nicht helfen, bitte nochmal melden, dann versuch ich mal einen anderen Compiler drauf anzusetzen (könnte dann zwar schwierig werden mit der 64-Bit-Version, aber das wäre dann in Kauf zu nehmen).
"Those who would give up essential Liberty to purchase a little temporary Safety, deserve neither Liberty nor Safety." - Benjamin Franklin



Laa shay'a waqu'in moutlaq bale kouloun moumkine. - Nothing is true, everything is permitted.

Beiträge: 1 151

Danksagungen: 152

  • Private Nachricht senden

8

17.02.2011, 14:17

Mit der Installation von C++ Redistributable Package funzt es einwandfrei.

Nihalejh

Schüler

Beiträge: 91

Danksagungen: 21

  • Private Nachricht senden

9

17.02.2011, 15:28

ja super funktioniert jetzt. Danke dir :)

lg Sami

Ich diskutiere nicht mit Idioten, die ziehen mich sonst auf Ihr Niveau hinunter und schlagen mich dort dann mit Erfahrung.

Absalom

Schüler

Beiträge: 94

  • Private Nachricht senden

10

17.02.2011, 17:40

Herzlichen Dank, nun flutsch es wie ne Eins dahin. :thumbsup:

Social Bookmarks